On-Core Software
December 05, 2019, 10:40:45 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1] 2
  Print  
Author Topic: ShotMaxx Trainer Android not receiving times  (Read 23471 times)
Adam
Administrator
Hero Member
*****
Posts: 992



« on: April 03, 2014, 08:50:11 am »

We've had a few reports of the SMT not receiving times on the Android version.  For some reason the Android Bluetooth seems to stop working correctly and what you need to do is Reboot your device.

Press the power button on your device until the dialog box appears and choose "Power off".  Wait for it to completely shut down.  Then press the Power button again until it boots.  That should get this working again.  Also note to make sure that the ShotMaxx (SM) timer has "Send" set to "on".  When it is "on" and the SM serial # shows up in green in the App, you should be good to go.  If it stops working at a later date, you may need to reboot again.
Logged
Tbk
Newbie
*
Posts: 1


« Reply #1 on: May 07, 2014, 03:24:13 am »

I have an Galaxy S4 Active.

In Shotmaxx Trainer i can se my Shotmaxx device, but no matter what i do (reboot, etc) it won't read any information from the Shotmaxx timer.

The trainer app is the latest and my firmware on the Shotmaxx timer is flashed with latest firmware.

Also when i try to register shoot's manual it wont work properly as i only manage to enter seconds and not decimals (tho i can read from the update log that this is supposed to been fixed.)
(My phone language is Norwegian btw.)

I also find it a bit wierd to say that the error is on the shotmaxx timer if trainer app works on IOS since then the problem points in the direction of the app.

Hope u get this sorted out since this app is why i got the timer.

Regards
Logged
Adam
Administrator
Hero Member
*****
Posts: 992



« Reply #2 on: May 08, 2014, 06:06:58 pm »

I have an Galaxy S4 Active.

In Shotmaxx Trainer i can se my Shotmaxx device, but no matter what i do (reboot, etc) it won't read any information from the Shotmaxx timer./

One other user with a Droid Razr is having the same issue.  We asked him if he could try it on any other devices, but unfortunately he does not know of anyone with an iPhone or iPad that he could try it with.  He sent back the watch to CED and we will see what they say.

If you have access to an iPad, please download our free Steel Scoring app and try to see if that works?  We still don't know if it's a SM issue or Android issue.

Quote
The trainer app is the latest and my firmware on the Shotmaxx timer is flashed with latest firmware.

Also when i try to register shoot's manual it wont work properly as i only manage to enter seconds and not decimals (tho i can read from the update log that this is supposed to been fixed.)
(My phone language is Norwegian btw.)

What do you use for a decimal delimiter there?  In the US we use a period ".".  In some countries they use a comma "," instead.  The keypad is set to use whatever delimiter is used for your "Region", based on your system settings.  What do you see on the keypad?

Quote
I also find it a bit wierd to say that the error is on the shotmaxx timer if trainer app works on IOS since then the problem points in the direction of the app.

Have you tried yours on an iOS devices?  Our SM's work just fine on our Google Nexus 7.

Quote
Hope u get this sorted out since this app is why i got the timer.

We hope so too.  We still don't know if it is a hardware issue or an Android device issue?  There are others using it on Android devices with no troubles, but one other guy that is having a similar problem to yours.  Based on the Google log files it appears that there are several Galaxy S IV users out there (almost 1/5 of the users).
Logged
Dre
Newbie
*
Posts: 9


« Reply #3 on: June 18, 2014, 06:32:35 am »

I received my ShotMaxx yesterday.
I can’t get the app to receive times nor can I get it to start a drill.
The phone flashes the message ”Start Session Sent” when the red start button is pressed but nothing happen with the watch.
When Pressing and holding both the Rev and Light button for about 1 second the screen on the watch says “Wait” but nothing is recorded on the phone.

The device is connected to the phone and the app correctly registers the SMX-xxxxxxx ID (with green letters/numbers). When sEnd is set to ”off” the app correctly shows that the ShootMaxx is Disconnected (in red letters).

The watch is updated with the latest firmware revision (3049).
Latest version of the ShotMaxx Trainer app is installed (1.2.3 Android).
The phone is a Samsung S4 (GT-I9505) with Android 4.4.2 installed (bought in Sweden). Language used in the phone is English.
Logged
Adam
Administrator
Hero Member
*****
Posts: 992



« Reply #4 on: June 18, 2014, 09:11:59 am »

There is an issue with the ShotMaxx (SM) where it is not "listening" for commands sent to it.  We have reported this issue and they are looking into it.  So for now, don't rely on sending the Start or Parameters from an app to the SM.

Your best bet is to start timing by pressing the Start button on the SM and then the Rev to send the Last Shot / Num of Shots.  If you want to resend all shots, you have to press Rev+Light button to replace the LSNS.

So far it seems that the Samsung's work well.  One user with a  Droid Razr could not get it to work at all.  He switched to a Samsung and it worked fine with the SM.
Logged
Dre
Newbie
*
Posts: 9


« Reply #5 on: June 18, 2014, 12:39:48 pm »

To clarify.
When Pressing and holding both the Rev and Light button for about 1 second the screen on the watch says “Wait” but nothing is received by the application.

So neither send nor receive works...
Logged
Adam
Administrator
Hero Member
*****
Posts: 992



« Reply #6 on: June 18, 2014, 12:49:45 pm »

Please try rebooting your Android device and let us know if that helps?
Logged
Dre
Newbie
*
Posts: 9


« Reply #7 on: June 18, 2014, 02:19:40 pm »

I've played around with it for a couple of hours but I just can't get it to work.
I've tried rebooting the phone many, many times. Tried it in different combinations with the "soft" reset that the ShotMaxx gets when removed from charging. Also tried a multitude of different settings on the ShotMax but no dice. I've never gotten anything to work except the synchronization.
Would have tried it on a different Android device but the Android version on my old HTC Desire isn't supported and I don't want to pay for it again to try it on someone else phone.
Logged
Dre
Newbie
*
Posts: 9


« Reply #8 on: June 18, 2014, 03:11:48 pm »

Don't know what changed but it's working now.
Logged
Nbk911
Newbie
*
Posts: 6


« Reply #9 on: July 28, 2014, 05:31:22 pm »

Still nothing works on my samsung mini s4


latest firmware
latest app version

nothing never worked!
Logged
Nbk911
Newbie
*
Posts: 6


« Reply #10 on: September 07, 2014, 03:01:27 pm »

It seems to work now and the batch option is very nice

Thanx
Logged
NoFe2O3
Newbie
*
Posts: 8


« Reply #11 on: November 16, 2014, 08:34:33 am »

I have the same problems as reported by Dre and Nbk911.  Unfortunately, however, mine still does not work.  Latest firmware (3085) on a Samsung Galaxy S3.  I can get the devices paired, and the SM timer shows up in green on the Trainer app.  But I can't get the app to start the timer, nor will the timer send data to the app.

I've booted, re-booted, soft-booted, all to no avail.

Like others, one of the reasons to buy both the timer and the trainer app was that I thought I would get a record of my drills.  This makes me wonder if I should just send everything back for refunds and start with a different setup.
« Last Edit: November 16, 2014, 09:06:49 am by NoFe2O3 » Logged
Adam
Administrator
Hero Member
*****
Posts: 992



« Reply #12 on: November 16, 2014, 10:15:03 pm »

In one of the last versions we had to do some major modifications to the "receiving" on Samsung devices.  Unfortunately Samsung is trying to be "too smart" with the Bluetooth audio.  Instead of the proper waveform that should be perfectly flat, the Samsung devices amply the signal as it is playing and thus ruins it (as it is no longer a valid "digital" signal embedded in the audio).  We had to basically write a audio compression/limiter for the Android devices.  That is why is is now working for most of the others.

The "Start" function has always been problematic on the SM watch.  It only worked "sometimes" at best.  I would only recommend using the Start button on the SM watch itself.  As far as receiving information, it *should* work.  All I can suggest is that you try reflashing the watch one more time.  That will make sure it is "reset".  When trying to send the times to the SMT app, make sure that the SM watch is within a couple feet of the device.  if you are too far away, it will drop some or most times being transmitted.  We've found that over 20 or so feet, it basically won't have enough signal strength to transmit/receive a valid signal and you won't get any times.
Logged
NoFe2O3
Newbie
*
Posts: 8


« Reply #13 on: November 17, 2014, 07:48:12 pm »

I have re-flashed, and I managed to get one set of data from the timer to the app.  But the next time I tried, it (again) failed to pick up the info.  My distance between timer and phone was about a foot.
Logged
Adam
Administrator
Hero Member
*****
Posts: 992



« Reply #14 on: November 18, 2014, 01:54:08 pm »

Usually when it is within 2 feet, it is very reliable.  Do you have any other Android or iOS devices you can test this with?  There is a small possibility there is also and issue with your SM.  We had seen one SM watch that the BT was not working correctly and had to be replaced by DAA for that person.
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!